aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/media/Kconfig
diff options
context:
space:
mode:
authorMauro Carvalho Chehab <mchehab@infradead.org>2008-07-17 22:25:53 -0300
committerMauro Carvalho Chehab <mchehab@infradead.org>2008-07-20 07:28:49 -0300
commitd4216488c0ccf7b659411023903bac7207f0dfb7 (patch)
tree88d23d677f02a65ccfe446ed028222eb80d426cc /drivers/media/Kconfig
parentc3fb62bf927cee771c3bcd5053e393e7df518f28 (diff)
V4L/DVB (8392): media/Kconfig: Convert V4L1_COMPAT select into "depends on"
Signed-off-by: Mauro Carvalho Chehab <mchehab@infradead.org>
Diffstat (limited to 'drivers/media/Kconfig')
-rw-r--r--drivers/media/Kconfig5
1 files changed, 2 insertions, 3 deletions
diff --git a/drivers/media/Kconfig b/drivers/media/Kconfig
index 7a7803b5d497..93ea201f426c 100644
--- a/drivers/media/Kconfig
+++ b/drivers/media/Kconfig
@@ -38,7 +38,6 @@ config VIDEO_ALLOW_V4L1
bool "Enable Video For Linux API 1 (DEPRECATED)"
depends on VIDEO_DEV && VIDEO_V4L2_COMMON
default VIDEO_DEV && VIDEO_V4L2_COMMON
- select VIDEO_V4L1_COMPAT
---help---
Enables drivers based on the legacy V4L1 API.
@@ -49,9 +48,9 @@ config VIDEO_ALLOW_V4L1
If you are unsure as to whether this is required, answer Y.
config VIDEO_V4L1_COMPAT
- bool "Enable Video For Linux API 1 compatible Layer"
+ bool "Enable Video For Linux API 1 compatible Layer" if !VIDEO_ALLOW_V4L1
depends on VIDEO_DEV
- default VIDEO_DEV
+ default y
---help---
Enables a compatibility API used by most V4L2 devices to allow
its usage with legacy applications that supports only V4L1 api.

Privacy Policy