aboutsummaryrefslogtreecommitdiffstats
path: root/utils/keytable/bpf_protocols/Makefile.am
diff options
context:
space:
mode:
authorSean Young <sean@mess.org>2018-11-07 12:10:07 +0000
committerSean Young <sean@mess.org>2018-11-07 23:24:34 +0000
commitdd3ff81f58c4e1e6f33765dc61ad33c48ae6bb07 (patch)
tree9a03946406479586852302b5b59565f8e46e038f /utils/keytable/bpf_protocols/Makefile.am
parentd2bf051b1a95a3ed0b0aa252816291800b3e6117 (diff)
keytable: fix BPF protocol compilation on mips
clang -idirafter /usr/local/include -idirafter +/usr/lib/llvm-6.0/lib/clang/6.0.1/include -idirafter +/usr/include/mips64el-linux-gnuabi64 -idirafter /usr/include +-I../../../include -target bpf -O2 -c grundig.c > In file included from grundig.c:5: > In file included from ../../../include/linux/lirc.h:10: > In file included from /usr/include/linux/types.h:9: > In file included from /usr/include/linux/posix_types.h:36: > In file included from +/usr/include/mips64el-linux-gnuabi64/asm/posix_types.h:13: > /usr/include/mips64el-linux-gnuabi64/asm/sgidefs.h:19:2: error: Use a Linux +compiler or give up. > #error Use a Linux compiler or give up. This requires __linux__ to be defined. Signed-off-by: Sean Young <sean@mess.org>
Diffstat (limited to 'utils/keytable/bpf_protocols/Makefile.am')
-rw-r--r--utils/keytable/bpf_protocols/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/utils/keytable/bpf_protocols/Makefile.am b/utils/keytable/bpf_protocols/Makefile.am
index 8887b897..ba79742c 100644
--- a/utils/keytable/bpf_protocols/Makefile.am
+++ b/utils/keytable/bpf_protocols/Makefile.am
@@ -8,7 +8,7 @@ CLANG_SYS_INCLUDES := $(shell $(CLANG) -v -E - </dev/null 2>&1 \
| sed -n '/<...> search starts here:/,/End of search list./{ s| \(/.*\)|-idirafter \1|p }')
%.o: %.c bpf_helpers.h
- $(CLANG) $(CLANG_SYS_INCLUDES) -I$(top_srcdir)/include -target bpf -O2 -c $<
+ $(CLANG) $(CLANG_SYS_INCLUDES) -D__linux__ -I$(top_srcdir)/include -target bpf -O2 -c $<
PROTOCOLS = grundig.o pulse_distance.o pulse_length.o rc_mm.o manchester.o

Privacy Policy